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What You Need to Run Lime™ 

Lime will run on all IBM compatible machines that will run Windows™ NT, 98, ME, 2000, 
XP, and Vista. Lime will run on all computers that run Macintosh® software using OS9 or 
OSX.  

Windows users: A Windows™ compatible MIDI card or USB-MIDI interface is required.  

Macintosh users: A MIDI interface is strongly recommended.  

A MIDI keyboard and MIDI synthesizer are strongly recommended for use with Lime. 

When you are ready to print the final draft of your Lime piece, do so on a PostScript® printer, 
or use a third-party tool to make a high-quality PDF file and print that on a non-PostScript 
printer. .  

This manual assumes you are familiar with Windows or Macintosh. It assumes you know how 
to use the mouse and know what “click,” “double-click,” “Shift-click,” “Alt-click” 
(Windows) or “Option-click” (Macintosh), and “click-drag” mean. It also assumes you know 
how to use menus.  

Lime Viewer 

A Lime Viewer is available for free download at www.cerlsoundgroup.org. With the Lime 
Viewer you will be able to open, read, and print, but not edit Lime files. The full-featured 
version of Lime requires registration after a trial period. The Lime Viewer will not expire and 
does not require registration. 
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How to Install Lime™ for Windows™ 

If you are not an expert with Windows, ask a friend for help installing Lime. This is the 
installation procedure: 

Copy the Lime self-extracting archive (LimeInstallxxx.exe, where xxx represents the version 
number, e.g. LimeInstall712.exe) to the hard drive. If you are working over the net, download 
the file to your hard drive. 

Expand LimeInstallxxx.exe by double clicking on its icon.  

This will create a folder (the default folder is C:\Program Files\Lime) containing the Lime 
Manual and the Lime program with all its associated folders, fonts and files.  

The Marl and Tufa fonts will be in the same directory as the executable Lime file. Leave all 
these files together in one directory.  

After you are done, you can discard LimeInstallxxx.exe, or save it to a backup disk. 

To add Lime to the Start menu, first locate Lime.exe (C:\Program Files\Lime\Lime.exe) then 
drag it onto the Start button. You can also create a shortcut by dragging Lime.exe to the 
desktop. 

If you have problems with your MIDI connection: Check the cabling to your synthesizer, 
and check synthesizer settings. The “out” cord should be connected to the synthesizer MIDI 
In. The “in” cord should be connected to the synthesizer MIDI Out. Check the settings in 
MIDI Input and MIDI Output under the Hear menu. Make sure you have MIDI Transmit 
enabled on your synthesizer. Make sure your synthesizer's Receive Channels are set properly. 
If you select Local Control Off on your synthesizer, you need to select Make Sound for 
MIDI Input in Options under Lime's Edit menu. 

If you would like to use Lime’s Print menu option to make high-quality PDF files, you must 
follow the special procedure in this manual’s description of the Print menu option (under the 
File menu).  
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How to Install Lime™ for Macintosh OS 9 

If you are not an expert with the Macintosh, ask a friend for help installing Lime. This is the 
installation procedure: 

1) Extract the LimeXXXos9.sea files. Lime is stored in a compressed file called 
LimeXXXos9.sea (where XXX represents the version number). (Lime exists on the server 
as LimeXXXos9.sea.hqx. Most browsers will automatically decode the hqx format.) To 
extract all Lime components, double-click on Lime.sea, specify the destination hard drive 
and folder, and hit Extract. Lime will take about 2 megabytes of space on your hard disk. 
You may throw away Lime.sea, or archive it for later use. 

2) Set memory. Set how much memory is allocated to Lime: Select the Lime application, 
use Get Info, and set the Application Memory Size. You should allocate at least 12000k to 
Lime; the more you allocate, the larger your scores can be. 

3) Install fonts. Open Lime's Fonts folder and drag the Marl and Tufa files from there onto 
your System Folder icon.  

4) Connect MIDI. If you are using MIDI you will need a third party MIDI interface. The 
Lime package includes MIDI Manager, but also supports OMS. We recommend you use 
OMS (Open Music System), which is available for free download at www.opcode.com. If 
you do not have MIDI equipment Lime will use QuickTime for playback. If you are using 
QuickTime no further installation is necessary.  

5) Install OMS. After downloading OMS, double-click on the file “Install OMS” and follow 
the instructions provided with this installation program. Launch OMS Setup and follow 
the instructions for a new setup. Launch Lime and open a new piece. Choose OMS MIDI 
Input… or OMS MIDI Output… from the Hear menu and select a method of MIDI 
input or output. You can choose QuickTime Playback (if that option is enabled in OMS) 
or any MIDI synthesizer that is available through your OMS setup. OMS and 
QuickTime: If you would like to use OMS for QuickTime playback, double click on the 
QuickTime Music icon and check “on.”  

6) Restart your computer.  

If you have problems with your MIDI connection: Check the cabling to your synthesizer, 
and check synthesizer settings. “Out” ports should be connected to “In” ports and vice versa. 
Check the settings in MIDI Input and MIDI Output under the Hear menu. Make sure you 
have MIDI Transmit enabled on your synthesizer. Make sure your synthesizer's Receive 
Channels are set properly. If you select Local Control Off on your synthesizer, you need to 
select Make Sound for MIDI Input in Options under Lime's Edit menu. ).  
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How to Install Lime™ for Macintosh OS X 

If you are not an expert with the Macintosh, ask a friend for help installing Lime. This is the 
installation procedure: 

1) Extract the LimeXXXosx.app.sit files. Lime is stored in a compressed file called 
LimeXXXosx.app.sit (where XXX represents the version number). (Lime exists on the 
server as LimeXXXosx.app.sit.hqx. Most browsers will automatically decode the hqx 
format.) To extract all Lime components, double-click on LimeXXXosx.app.sit, specify 
the destination hard drive and folder, and hit Extract. Lime will take about 2 megabytes of 
space on your hard disk. You may throw away LimeXXXosx.app.sit, or archive it for later 
use. 

2) Install TrueType fonts. Copy the Marl.ttf and Tufa.ttf files from Lime's TrueType Fonts 
folder and into your …/Library/Fonts folder.  

3) Connect MIDI. If you are using MIDI you will need a third party MIDI interface. The 
Lime package supports OSX’s CoreMIDI. If you do not have MIDI equipment Lime can 
use QuickTime for playback.  

 

If you would like to use an external MIDI keyboard but use the internal QuickTime 
synthesizer, you will need to install SimpleSynth.  SimpleSynth allows Apple’s QuickTime 
product to work with Apple’s CoreMIDI product.  SimpleSynth is available at 
http://pete.yandell.com/software/ 

 

If you would like to use Lime’s Print menu option to make high-quality PDF files, you must 
follow the special procedure in this manual’s description of the Print menu option (under the 
File menu).  
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Part I: Getting Started 

A Step-by-Step Example 

To teach you how to use Lime, this manual will begin with instructions for opening and 
editing a simple piece, the first four bars of “Lullaby of Birdland” (B. Y. Forster, George 
Shearing) shown below. You will want to read this manual as you sit at your computer, so you 
can follow the step-by-step instructions given here.  
 

 

For this example we will use a Stationery Pad or Template. A Stationery Pad or Template is a 
document that has all the parameters set (such as number of voices, layout, titles), but 
contains no music. If you would like to create a piece from scratch, see Creating a New Piece 
below. 

This example assumes Lime is running; if Lime is not running, launch the program and then 
go on.  

Open the File 

Open the “Templates folder” or “Stationery folder” and double click on the file “First Piece.”  
You will see a blank page with a title, staff, key, and blank measures.  

A Template is simply a starting point for a new piece. You may want to make some initial 
changes to accommodate the piece you are working on. In this example we will enter a 
melody in the key of A-flat. To insert a key signature of four flats, click on the first rest in the 
piece (it will flash), then select Key Signature under the Symbol menu. Specify four flats and 
click OK.  

It is possible to create your own template copies of layouts that you use often. If, for example, 
you plan to do a series of melodies in A-flat major, you can save this newly modified file as 
“Single Voice-A-flat Major” and use it as a template. Many users find it useful to set up a 
layout with all the voices, instrument names, staff arrangements, format, numbering format, 
etc., but no music. This file is then a “stationery pad” to be used over and over, but saved as a 
separate file after music has been entered. Mac users: To change an existing file into a 
stationery file use the Finder to select the new file, choose Get Info under the File menu and 
check “Stationery Pad.” Windows users: To change an existing file into a template use 
properties to make the file “read only.” 
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Note Entry 

Before entering notes you must identify the edit point or insertion point. In this example we 
will begin entering notes in the first measure: Double click on the rest in the first measure or 
choose Note Entry (under the Voice menu). A flashing box should appear around the rest. 
This is called a “note-entry cursor.”  

At the bottom of the screen is the “Piano Window.” It has a drawing of a piano, plus a rest 
bar and other symbols. (The Piano Window may be relocated by dragging the lower right-
hand corner. In these examples the Piano Window has been relocated just below the music to 
conserve space.)  This piano can be used with the mouse if you do not have a MIDI keyboard. 
Before you click on a piano key, choose the note value you need by clicking on the 
appropriate symbol just below the piano. For this example we will use an eighth note. 
(Clicking again on the eighth note symbol will select a dotted eighth; a third click gives a 
doubly dotted eighth.)   

 

 

The middle C key on the screen is specially marked1. Now click on the C key above the 
middle C and watch the screen. At first, you may see the mouse cursor momentarily turn into 
an arrow-watch (Windows) or a hollow arrow (Macintosh) to indicate that the screen is not 
up-to-date yet, and the four-measure-rest symbol turn gray, to indicate that it has been 
changed. After a short time2 the display will show your eighth note C, followed by an eighth 
rest and three beats of rest and then three more measures of rest. The note-entry cursor has 
moved to the eighth rest. 

 

                                                 

1 This mark will move when Keyboard Shift is used.  

2 On newer machines the update time is negligible. 
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Now play the rest of the notes for Lullaby of Birdland by clicking3 on the Piano Window. 
When you get to a quarter note, remember to click the quarter note symbol in the piano 
window; then, after you play the quarter note remember to click the eighth note symbol before 
you go on. (The next note will be an eighth note.) 

You can replace a wrong note by double-clicking on it and playing a new note. If you replace 
a half note with a quarter note, then you will also get a quarter rest. Similarly, if you replace a 
quarter note with a half note, then the quarter note and the quarter note after it will be 
replaced. 

If you want to delete a single note, click on the note, and hit the Delete key. It is possible to 
select a group of notes and delete them (see Note Group Select below), but if you intend to 
replace the notes with new music it is just as fast to enter the new music over the existing 
notes.  

In this little sample piece we don't have any chords. You can play chords with the mouse by 
clicking on all the notes in the chord while holding the Shift key. It is much easier to use a 
MIDI keyboard if you have one. In this case, simply play all the notes in the chord 
simultaneously. A single voice can contain a chord with any number of notes. A chord on a 
single staff can be the result of several voices, one note per voice, or a single voice containing 
chords.  

The next pitch in the example is an eighth note tied to a quarter. There are two methods for 
adding ties, slurs, dots, accents, etc.; selecting the symbol before entering the note, or using 
the Edit Cursor to add the marking after entering the notes. We will demonstrate the first 
method here.  

To enter the tied eighth, first click on the “tie” in the piano window. Check to make sure the 
eighth note symbol is still selected. If not, select it. (Do not select it again. This will change it 
to a dotted eighth; a common error among beginning users.) Click on the D-natural. It is not 
necessary to select the natural symbol in the piano window. Lime will enter the pitch with the 

                                                 

3 Entering notes with the mouse as described here is the easiest and most intuitive method, but it is also the 
slowest. Using the computer keyboard, Piano Window Keys or a MIDI piano keyboard, are described below.  
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correct accidental. (Use the accidental symbols to force an accidental other than the default, or 
to change to an enharmonic pitch such as A-flat instead of G-sharp.)  

The tie is deselected automatically, but you must select the quarter symbol before entering the 
next quarter note D-natural. Enter the eighth F and E-natural tied to the quarter E-natural. To 
enter the eighth rest, first select an eighth duration by clicking on the eighth symbol. Then 
click on the rest symbol at the end of the piano keyboard drawn on the screen or on the 
narrow gray strip just below the keys on the piano. For more details, see the Piano Window 
section below.  

Edit Cursor 

When you have finished entering all the music, you can return to the “edit cursor” (single note 
flashing) by clicking (single click) on any note or by deselecting Note Entry (under the Voice 
menu). With this cursor you cannot enter new notes, but you can change the appearance of 
piece by adding slurs, ties, dots, keys, clefs, time signatures, etc. Any of the items in the 
Piano Window and any item in the menus that are not gray are available for editing when 
using the edit cursor. Most editing features that are available with the edit cursor are also 
available with the note entry cursor. 

Position the edit cursor on the quarter note F. Click on the accent symbol in the piano window 
to add an accent.  

Note Group Select 

Lime provides a “Note Group Select” feature that allows you to select and manipulate a 
group of notes. Normally, just one note or rest is selected, and it flashes continually. When 
Note Group Select is used, a whole set of notes is selected; the selected notes are highlighted. 
Go to the beginning of the piece, and select all the notes in the first measure by dragging the 
mouse (click and press the mouse button as you drag the mouse).  

When you complete the drag and let up the mouse button, the notes are highlighted and the 
music symbol at the bottom left of the screen will be gray. To select additional notes (add 
more notes to the selected group) use the Shift key while dragging a box around the new 
notes. Go to the second measure in the piece, and select three more notes by Shift-dragging. 
These notes are selected in addition to those notes you already have selected. (If you Shift-
drag around notes that were already selected, they are deselected. If you drag over new notes 
without pressing the Shift key, those notes will be selected and the previously selected notes 
will be deselected.) Do not select the quarter note E-natural.  
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Now click on the word “slur” in the Piano Window. Note that the final E is included in the 
slur. This is because a slur extends from the selected note to the next note. For this reason, 
when adding a slur, you must not include the last note to be contained under a slur. Click on 
the staccato symbol in the Piano Window; this makes all the selected notes staccato; click 
again for staccatissimo. . Select No Stem, Stem up, or Stem down under the Stem menu. 
Any of the symbols in the Piano Window that are not shaded and menu items that are not 
gray may be applied to the selected notes. A selected group of notes can also be deleted by 
hitting the Delete key. To end Note Group Select, just click on a single note in your music; 
this will select just that note, and end Note Group Select. Finally, to get rid of the staccato 
dots you just added, Note Group Select the same notes, and click on the staccato symbol to 
remove its shading; then click on one of your notes to end Note Group Select again. You can 
also use Undo (under the Edit menu) to remove the markings. In fact, you can continue 
choosing Undo to revert back to the beginning of the editing session. 

Piano Window Shading and Menu Check Marks 

Lime illustrates which edits have been applied to each note with a dark shading in the Piano 
Window and a check mark in the menus. Click on just one of the notes you have just changed 
then one of the notes that has not been changed and notice how the shading in the Piano 
Window changes. Click on the Stem menu and notice the check marks on each of the notes. 
When a group of notes are selected and there is a mix of edit options (in the example above 
some notes have ties, some do not, some have accents, others do not), the Piano Window 
item is shaded, not dark. The menu item has a grayed check (Windows) or dash (Macintosh) 
rather than a regular check. 

If you need to change the length of individual notes you should reenter the music using the 
correct note lengths. If you select Enable Duration Edits (under the Edit menu), it is 
possible to change the value of the note indicated by the edit cursor (including tuplets) by 
clicking a length in the Piano Window. This operation is available for correcting OMR 
(Optical Music Recognition) errors in scanned music or imported MIDI files. It should not be 
used when doing standard copy since the length of the measure is changed along with the 
note length. Conflicting measure sizes will result, particularly in multiple voice works, if this 
option is used incorrectly. 

If you select Enable Duration Edits, the Kill symbol is also used to correct errors in scanned 
music. It removes unwanted notes without preserving the size of the measure. Likewise, Kill 
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should be used with care or conflicting measure sizes will result. Normally the Delete key is 
used to replace notes with rests.  

Adding Lyrics 

Now click on the first note in the piece. You may have to use the scroll bars to bring the first 
note onto your screen.  

There are four symbols at the left of the Piano Window. The top symbol is for entering 
music, the bottom three are for various kinds of annotations: text (and other symbols found in 
fonts), lines, and curves. Select Text Category, Lyric (under the Annotation menu). This 
will highlight the text symbol (letter A) at the left of the Piano Window; this allows you to 
type lyrics under your note. 

 

 

Now type the word “Lull-” (include the hyphen). It will appear underneath the first note. Then 
press Tab to move to the next note. Type "a-", press Tab, then type "by". Continue to type the 
lyrics using Tab4 to move to each new note and typing each part of the lyric underneath each 
note. There are two useful features already selected in the Annotation, Style menu that will 
make entering lyrics easier. Center Hyphen centers the hyphen if it is the last character in an 
annotation. (So type “la-“ and “Bird-” for this example.) And Extend Underline replaces an 
underscore, if it is the last character in the annotation, with a line. (So type “that’s_” and “I_” 
under the eighth note D and E.)  

If you make a mistake, select the incorrect lyric by pressing Alt (Windows) or Option 
(Macintosh) and clicking near the beginning of the lyric (hold down the Alt or Option key as 
you click). Then use Clear Annotation (under the Edit menu) or press the Delete key, and 
re-type your text. You can also select Previous or Next Annotation (under the Annotation 
menu) to move through annotations for modification. Similarly you can press Alt (Windows) 
or Option (Macintosh) and the left or right arrow keys to move between annotations.  

Once an annotation is selected you can hit Enter or Return to position the cursor at the end 
of the annotation for editing. You can also select a section of the text after it has been selected 
to delete or edit. When you have finished, click the notes symbol (the top symbol) at the 
bottom left of the screen. You can also exit Annotation Mode by pressing the Esc key. For 

                                                 

4 It is possible to switch the Tab and Space Bar in the Options dialog. Some users find it easier to use the 
Space Bar to move to a new note.  



Lime™ User’s Manual 
 

21 

more details on lyrics, see the description of Annotation Mode and Annotation menus 
below. 

If you have two lines of lyrics, you can type the first line for all the notes on the page (using 
Tab between notes); then you can click on the first note, and type the second line for all the 
notes on the page.  

Some users find it easier to use the space bar to advance to the next annotation when entering 
lyrics. There is an option (Options under the Edit menu) that will allow you to swap the 
function of the tab key and space bar. With this option engaged the space bar will advance to 
the next note and the tab key will type a space.  

While still in Annotation Mode click on the first note in the example. Choose Text 
Category, Chord Symbol under the Annotation menu. Choosing Chord Symbol has no 
apparent effect on the annotation when they are entered. But chords that have this designation 
will automatically transpose with the music if you change keys.  

To reposition the cursor Control (Windows) or Command (Macintosh)-click above the note 
at the position where you want the chord symbol to appear. Use the Text Assistant (under the 
Annotation menu) and choose Chord Symbol to create each chord. Use Tab to move to the 
next note where a new chord symbol is used. It is possible to type in chord symbols without 
the Text Assistant. Special characters such as sharps and flats can be entered using the 
backslash convention described in the sections that follow. 

It is important to remember that each annotation is assigned to a note. In this example, each 
lyric and each chord symbol should be attached to the note with which it corresponds. This 
allows Lime to maintain the relationship between the annotation and the note if the note is 
moved to another location, such as the next system. 

You can also change existing annotations; for example the title or tempo markings in a 
template file. You can press Alt (Windows) or Option (Macintosh) and click to select the 
annotation. Then position the cursor to delete or change existing text. You can also use Clear 
Annotation (under the Edit menu) and reenter the title from scratch.  

Copy, Paste, and Multiple Paste 

Lime has a variety of copy and paste capabilities. To copy notes select the notes you want to 
copy with Note Group Select, and use Copy Music (under the Edit menu). Alternatively, 
you can click on the first note you want to copy and use Copy Measures… (under the Edit 
menu). After you use Copy Music or Copy Measures… click elsewhere in the piece and use 
Paste Music (under the Edit menu). 

You can use the scroll bars to scroll around the page. Alternatively, you can press Alt and 
Control (Windows) or Option and Command (Macintosh) while you move the mouse to the 
edges of the music window; this is called “Magic Scrolling.” 
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Lime also allows you to copy and paste annotations. Select the annotation by pressing Alt 
(Windows) or Option (Macintosh) and clicking next to it. Then use Copy Annotation (under 
the Edit menu). Now you can click elsewhere in the piece and use Paste Annotation (under 
the Edit menu). Alternatively, you can do a “Multiple Paste:” select several notes using Note 
Group Select and then use Paste Annotation. Your annotation will automatically be pasted 
to all the notes that are selected. 

Multiple Paste is an economical method of annotating a large score. For example, a score 
may call for 8 throughout a piece. Start by entering all the notes. Then, click on the first note 
which needs a 8, select the text symbol, select 12-point Marl font, type the 8 (press the 8 
key; Marl font charts are in the back of the manual), and use Alt-drag to adjust its position. 
(You may find it simpler to add the trill using the Text Assistant in the Annotation menu, or 
typing the backslash expression \tr in a text font; both these approaches are described later in 
this manual.)  Once you have the 8 on the first note, you can easily copy and paste it to other 
notes using Multiple Paste. Alt (Windows) or Option (Macintosh) click on the 8, use Copy 
Annotation, use Note Group Select to select all the other notes on the page that need the 8 
symbol, and use Paste Annotation. You will find that proper use of the annotation controls 
(such as Horizontal Lock and Vertical Lock, under the Annotation, menu) will help you 
make good use of Multiple Paste. For a 8, turn off Horizontal Lock. Turn Vertical Lock on 
if you want the 8 pasted the same distance from the staff line wherever it is pasted; turn 
Vertical Lock off if you want the 8 to move up and down depending on the pitch of the note 
to which it is pasted. 

Experiment 

After learning the basics of Lime you will probably want to experiment. Most of the menu 
items, such as Hear, Print, Key Signature, etc., are self-explanatory. Open each one and 
read the options.  If a menu item is unclear, you will want to read about them in the manual. 
You might also glance through the Hints and Examples section and try to reproduce some of 
those examples. It will be constructive to experiment for a while before you transcribe your 
first piece. As you gain experience and become more familiar with the Lime environment, 
your speed of music transcription will increase dramatically. 

When you begin working on your first serious transcription, use Save and Save As (under the 
File menu) frequently. This way you will be able to use Revert (under the File menu) to go 
back to the most recently saved version of your piece if you make changes you do not like. It 
is always a good idea to Save just before an operation that may drastically change the look of 
the piece (such as Systems changes, Layout, or Part Extraction).  

Part Extraction 

Once you have completed a score, you can print out the score using Print (under the File 
menu). If you also want to print out individual parts, Lime has a mechanism called “notation 
contexts” to help you. Your piece starts off with only one notation context, the score notation 
context. Use Part Extraction… (under the Context menu) to create more notation contexts: 
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one notation context for printing each individual part. The notation contexts keep track of 
printing information for the score and parts.  

It is best to complete the score before you create the notation contexts for the parts. After you 
make all the parts notation contexts, changes you make in one notation context will be 
reflected in the other notation contexts. For example, if you correct a note in the flute notation 
context, the correction will automatically appear in the score notation context as well. 

Shortcut Keys, MIDI entry. 

So far we have entered notes, selected duration values and menu items using the mouse and 
the piano window on the computer screen only. This method is intuitive and user friendly, but 
very slow. It is much faster to use keyboard shortcuts and a MIDI piano. Keyboard 
equivalents take a little time to learn, but it is a worthwhile investment in the long run. There 
is a complete list of shortcuts at the back of the manual. Most shortcuts can be customized. 
Here are a few. 
• Pitches, chords, and rests can be entered using an external MIDI keyboard. To enter a rest 

press three adjacent keys on the piano keyboard (e.g. C, C-sharp, and D).  
• Many commonly used menu items have keyboard equivalents. The keyboard equivalents are 

listed on the right side of each of the menus.  
• Most items in the Piano Window can be engaged using the computer keyboard. Piano 

Window equivalents can be customized using Shortcut Keys… under the Edit menu. 
• The second and third rows (a, s, d, and q, w, e) are set to pitches beginning with C4. The [ 

and ] keys are set to keyboard shift.  
• The numbers on the keypad of an extended keyboard have been set to commonly used 

durations. With one hand on the computer keypad and one hand on the MIDI keyboard 
music can be entered as fast as one would type or play in real time; this is an alternative to 
real-time MIDI entry with Record… under the Edit menu. 
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Creating a New Piece 

In this section we describe how to create a piece from scratch. Start Lime by double clicking 
on the Lime icon.  

Under the File menu, select New. This is used to make a new piece.  

 

 

 

Initial Time Signature, First Part, and Number of Measures 

When you create a new piece, you are asked how many measures you want to start with, the 
starting time signature for your piece, a name for the first part and how many beats you want 
in each measure. If the piece you are working on uses changing time signatures, or different 
time signatures, they may be specified later. You can also insert more measures later; you will 
have to do this if the number of beats in a measure varies in your piece. (For example, if you 
are in 4/4 time but you have a 1-beat pickup measure, you will want to start by specifying the 
total number of 4/4 bars. Once the page of 4/4 measures appears you can click on the first 
note or rest and insert one measure of 1/4 for a pickup.)   
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You are also asked for the number of measures per system, and the number of systems per 
page. If your music is very dense, you will want few measures per system; if you have a large 
score, you will want only one system per page. For solo pieces, where each system has only 
one staff, you may want to put 10 or 15 systems per page. You will be able to change the 
number of measures on each system and page turns later, if you think certain systems are too 
crowded or too sparse, or if page turns are at bad places. 

Parts and Voices 

Lime uses a hierarchy of parts and voices that allows great flexibility when creating a score. 
The term “part” is used for a single musical instrument. The term “voice” is used to describe a 
line (usually indicated by stem direction) within a part. 

When you create a new piece, it always starts off with one part. You can choose Single Staff 
or Grand Staff. If you choose Single Staff, your piece will start off with one part consisting 
of one voice printed on one staff per system. If you choose Grand Staff, your piece will start 
off with one part consisting of two voices printing on two staves per system.  

Often several parts of several voices are combined on a single staff and appear as chords. But 
a single voice can also contain a mixture of melodic lines and chords.  

Once you have created your piece, you can use Parts and Voices (under the Voice menu) to 
create more parts and to arrange them on the score. If you are creating an orchestra score and 
you want two flute parts to print together on one staff, you should create two parts for the 
flutes; flute 1 and flute 2. Parts and Voices will let you specify that the flute parts print 
together on one staff in the score. If you are transcribing Bach's three part inventions, you will 
probably use three voices for the piano part. See the section on Parts and Voices for more 
information. 

Clefs and Key Signatures 

You can change the key signature and clef by using Key Signature and Clef under the 
Symbol menu. If your piece has several staves in each system, you can change keys or clefs 
on more than one part or voice at a time using Note Group Select: Shift-click the first note 
on each of the staves, then use the Key Signature or Clef menu options. 

If you want to print a score with transposing instruments, specify this using Key Signature. 
Use Current Staff Only in Key Signature to specify a key signature for each individual part. 
You also have to specify how many half steps to transpose in Key Signature. For example, an 
instrument in b-flat has a concert pitch two half steps down from the printed pitch, so specify 
“-2.”An instrument in f plays 5 half steps above printed pitch or 7 half steps below printed 
pitch, depending on the octave of the instrument. 
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The New Piece 

Once you have made any changes to the key, clef, number of measures or voices, you can 
begin to enter music, as explained in the previous section. You can use the scroll bars to scroll 
around the page. Alternatively, you can press Alt and Control (Windows) or Option and 
Command (Macintosh) while you move the mouse to the edges of the music window; this is 
called “Magic Scrolling.” 
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resize, 61 
local control off, 64 
Louder, 95 
low memory warning, 31 
lyrics, 34 
Lyrics, 151, 180 
Macintosh Lime files, 44 
magic scrolling, 21, 26 
tenuto, 29, 96 
margins, 50, 66, 131 
Marl, 13, 14, 109, 178 
measure numbering, 65 
measure numbers, 103 
memory usage, 31, 51 
mensuration, 171 
MIDI, 17, 37, 64, 76, 81 

channel, 80 
Channel, 37 
connections, 13 
connections, 12 
Control, 37 

files, 46 
Input, 98 
Messages, 37 
Note mapping, 37, 38 
Program, 37 

MIDI Input, 98 
MIDI Manager™, 13, 14 
Model for Text Category, 108 
Modify Playback, 96 
Modify Slur, 91 
Modify Tie, 91 
mouse click summary, 175 
multiple paste, 21 
Multiple Paste, 39 
MusicXML, 45 
New, 44 
New Voice, 78 
Next Annotation, 108 
Next Note, 82 
Next Page…, 70 
Next Part Or Voice, 75 
NIFF, 45, 140, 142 
No Stem, 88 
Not in Score, 32, 116 
Note Entry, 77 
note entry cursor, 27 
Note Entry Cursor, 77 
Note Menu, 82 
Noteheads, 180 
notes 

accidental stacking, 43 
accidentals, 28 
add notes to a chord, 30 
beaming, 89, 122, 146 
beaming between staves, 147, 149 
changing lengths, 19 
changing note lengths, 140 
correcting note lengths, 140 
cues, 29 
deleting, 17 
dotted, 28 
duples, 124 
grace notes, 29, 123 
grace notes, 96 
Group Select, 18, 39 
internal fields, 87 
lengths, 28 
tenuto, 29, 96 
new symbols, 30 
playback timing, 93, 96 
playback volumes, 95, 96 
quintuplet, 28 
relocation, 42 
replacing rests, 86 
selecting, 34 
slur, 29, 96 



Lime™ User’s Manual 
 

187 

slurs, 120 
spacing, 42, 50, 129 
special noteheads, 29 
staccato, 29, 96 
stems, 88 
ties, 120 
ties, 29 
triplet, 28, 124 
tuplets, 28, 85, 124, 166, 167 
tuplets, 113 

Numbers 
Page, Bar, Tuplets, 181 

occasional unpitched material, 172 
octave transposition, 98 
OMR 

Clear Graphical Alignment, 57 
clef errors, 100 
corrections, 139, 140, 142 
integrated into Lime, 47, 139 
key signature errors, 101 
Next Rhythm Error, 70 
red rests, 56, 139, 141 
Show OMR Image, 73 

OMR of Image File, 47 
OMR of Scanner, 47 
Only in Score, 32, 116 
Open, 44 
Optical Music Recognition, 45, 47, 139 
Option-click, 34, 35 
Options, 64 
page 

numbering, 65 
size, 50 
turns, 70 

Page 
new page, 73 

Page Menu, 70 
Page Setup, 51 
pallet files, 128 
Parameters, 38, 83, 106, 179 
Part extraction, 39, 67, 71, 132, 136 
part names, 58 
Parts and Voices, 25, 78, 125, 127, 147, 149 
paste, 21 

multiple paste, 21 
Paste 

Annotation, 39 
Multiple Paste, 39 
Music, 54 

Patchbay™, 13 
percussion staff, 78, 99 
piano fingerings, 146 
piano music, 123, 145, 147 
piano tablature, 79, 150 
Piano Window, 16, 27 

keyboard equivalents, 62, 177 

moving, 31 
Piano Window Keys, 177 
pickup measures, 130 
pitch bend, 81 
Pitch Bend, 91 
Play Octave Higher, 98 
Play Octave Lower, 98 
playback, 93 
Playback 

Earlier, 96 
Higher, 96 
Later, 96 
Longer, 96 
Louder, 96 
Lower, 96 
Shorter, 96 
Softer, 96 

points, 50 
polytempo music, 172 
Position Lock, 110 
Previous Annotation, 108 
Previous Note, 82 
Previous Part Or Voice, 75 
Print, 51 

Rectangle, 52 
to postscript, 52 

Print Multiple, 52 
Print Setup, 51 
printing scores, 78 
problems with MIDI, 12, 13 
Proportional Notation, 159 
quintuplets, 28, 124 
Quit, 53 
real-time input, 76 
Recompute Playback, 97 
Record, 76 
Recordare®, 45, 49 
red rests, 70, 141 
rehearsal marks, 60, 65, 110 
reminder accidentals, 29, 55, 82 
repeated chords, 158 
repeats, 103, 160 
Repeats, 179 
Rest, 181 
Rest Drag, 42 
Rest Number, 182 
rests, 28 

beaming over, 146 
combine, 28, 134 
combine, 102 
Don't Combine Rest, 85 
hide, 85 
multi-rest, 85 
not printed, 85 
red rests, 139, 141 
red rests, 56 
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Vert. placement, 42 
whole, 28, 85 
whole, 102 

Revert, 49 
Rulers, 35 
SATB system, 126, 151 
Save, 48 

Graphic, 48 
Save As, 48 
scannd music 

red rests, 56 
scanned music, 45, 47, 139 

Clear Graphical Alignment, 57 
clef errors, 100 
corrections, 139, 140, 142 
integrated into Lime, 47, 139 
key signature errors, 101 
Next Rhytm Error, 70 
red rests, 139, 141 

Schenker, 157 
scores, 41, 78, 135, 137 
screen 

magic scrolling, 21, 26 
music keyboard, 27 
not up-to-date, 16 
options, 27 

Select Twain Source, 47 
selecting annotations, 34 

summary, 175 
selecting notes, 34, 82 

summary, 175 
SharpEye Music Reader®, 45, 47, 56, 139, 140 
sheet music, 51 
Shift key, 17 
Shift-click, 62 
Shift-Copy Music, 55 
Shortcut Keys, 62 
shortcuts, 23, 177 
Show Accidental, 82 
Sibelius®, 45, 49 
slur, 19, 29, 91, 96, 120 
Slur 

Hanging, 91 
Slurs, 182 
Softer, 95 
Sonata, 65, 178 
space/tab option, 21 
spacing, 50, 129 
Spacing, 182 
Special Accidentals, 83 
Split Page, 70 
staccato, 18, 29, 96 
Stack Vertically, 111 
staff 

cue, 78, 127, 152 
empty, 79 

number of staff lines, 143 
Parts and Voices, 78 
percussion, 143 
percussion, 99 

Staff Drag, 41, 79 
Staff Labels, 135 
Staff Lines, 182 
Staff Size Adjust, 110, 152 
Stem, 181 

Between Staves, 88 
Down, 88 
Menu, 88 
Slashed, 88 
Up, 88 

Stem Between Staves, 148 
Stems 

extended, 160 
stretching lines and curves, 35 
style, 35 
Styles, 108 
summary, 175 
swing eighth, 91 
symbols 

changing Lime’s symbols, 106 
examples for creating, 123 
finding symbols in fonts, 137 

synthesizer connections, 12, 13 
System Bracket, 105 
Tab, 34 
tab/space option, 21 
tablature 

guitar, 78 
piano, 79, 150 

Tablature, 182 
Tablature String, 84 
tempo, 93, 171 
tempo markings, 37, 60, 137, 138 
text, 32 
Text Category, 109 
theory symbols, 126 
Thicker Middle, 33, 114 
tie, 91 
Tie 

Hanging, 91 
ties, 29, 120 
Ties, 182 
time signature, 171 
Time Signature, 73, 85, 102, 162, 163, 167, 168, 
182 

above staff, 161 
above staff, 162 
changing, 162 
custom, 162 

Times, 109 
timing, 93, 96 
titles, 136 
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Titles, 110 
Transpose Existing Notes, 101 
transposition, 25, 98, 100 
tremolo, 29, 90, 144 
Tremolo, 181 
Tremolo Beam, 90, 144 
triplets, 28, 65, 124 
Tufa, 13, 14, 109, 178 
Tuning, 94 
tunings, 81, 93, 94 
Tuplet Bracket, 113 
tuplets, 65, 124 
Tuplets 

partial, 161 
tuplets within tuplets, 167 
TWAIN, 47 
Underlined, 109 

Unsighted Lime users, 52 
Vertical Lock, 115, 119 
voice 

highlight, 80 
selecting notes, 82, 133 
splitting voices, 142 
staff to print on, 78 

Voice 
Voice to Staff Above/Below, 79 

Voice Menu, 75 
Voice on Channel, 80 
Voice to Staff Above, 79 
Voice to Staff Below, 79 
whole rest, 28, 102 
Windows Lime files, 44 
word processors, 56 
zoom, 50 

 
 




